Author Topic: Spartan quark gyro and Savox 1290mg servo  (Read 3695 times)

0 Members and 1 Guest are viewing this topic.

Offline benjiboy81

  • New member
  • *
  • Posts: 8
Spartan quark gyro and Savox 1290mg servo
« on: March 09, 2014, 04:06:03 PM »
I'm getting a lot of noise from the servo when plugged into the gyro. This is for my HK600GT and not having used either gyro or servo before, it's this right? servo seems to be working Ok and the gyro setup fine.

 If I tap the gyro a couple of times the servo noise stops until you give it a rudder input from my dx6i, then the nose starts again. I have the gyro mounted on top of the boom housing using the 3mm foam, metal plate then the 2mm foam pad as the manual says. I'm running a castle talon 90 esc. I get some noise from the servo plugging it in directly to the rx but nowhere near as much.

Any ideas of  What's causing this? Bad servo etc?

Cheers Ben

Offline jomac

  • Hero Member
  • *****
  • Posts: 595
  • Old Dogs can learn new Tricks
Re: Spartan quark gyro and Savox 1290mg servo
« Reply #1 on: March 09, 2014, 06:56:35 PM »
 :welcome: benji    Check to make sure your rod links are not to tight on the ball mounts, that in it self can create the servo chatter you talking about, also check too see if your tail slider is moving freely,  Best way to check is disconnect one link at a time, that should help you find the where the problem is
                                DH 9104/ Blade SR/ Align 450 V-2 Sport/ EXI 500/ HK 500 scale UH-1/RC Eye One quad/ Century G-20 Gasser/ E-flite Apprentice 15e/ Lanyu Cessna 1560mm

Offline benjiboy81

  • New member
  • *
  • Posts: 8
Re: Spartan quark gyro and Savox 1290mg servo
« Reply #2 on: March 10, 2014, 01:30:32 AM »
I will try that and report back

Offline benjiboy81

  • New member
  • *
  • Posts: 8
Re: Spartan quark gyro and Savox 1290mg servo
« Reply #3 on: March 10, 2014, 02:42:55 PM »
:welcome: benji    Check to make sure your rod links are not to tight on the ball mounts, that in it self can create the servo chatter you talking about, also check too see if your tail slider is moving freely,  Best way to check is disconnect one link at a time, that should help you find the where the problem is

I did as you suggested and it proved to be the app wasn't 100% straight and I to adjust the link rod and now the servo only chatters a little bit. Thanks for your help.

Offline Roundman54

  • Forum Service
  • Hero Member
  • *****
  • Posts: 1376
  • Hi I'm Duane I am a heli holic
Re: Spartan quark gyro and Savox 1290mg servo
« Reply #4 on: March 20, 2014, 06:02:07 PM »
Do you have your end points set rite? Also make sure all servo conectios are tight to your RX and Gyro.   :130:
  I need a 12step program for my Heli Addiction